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JustNN Introduction 
 
Welcome to JustNN, a simple and easy to use neural network application.  

 

Using JustNN you can: 

 

1.Import text, csv, spreadsheet, image or binary files into the Grid. 

2.Use many editing and pre-formatting functions on the grid.  

3.Build neural networks from the grid.   

4.Train, validate and query the neural network.  

 

New Users should do the Getting Started exercises.  

 

Neural Planner Software Ltd 
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Getting Started 
 

The exercises can be started by clicking the Getting Started button on the Tip of the Day or 
using the menu command Help > Getting Started... 
 
1.XOR 
 
In the first exercise you will open, train and query a simple neural network that simulates XOR, 
(exclusive-or).  XOR is a logical operator that results in the output being true if one of the inputs, 
but not both, is true. If both inputs are true the output is false. 
 
 
2.Color Circle 
 
In this exercise you will be guided through a series of steps to make a neural network that 
learns which secondary color is produced when any two of the three primary colors are mixed 
together. You will open a partially completed grid file. You will edit the grid and then create, train 
and query the neural network  
 
3.Races 
 
In the Races exercise you will start with an empty grid. You will then import the results of 370 
horse races. Then you will create, train and validate a neural network. When it is completed the 
neural network will be used to predict the results of other horse races. 
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Main Windows 
 

The main windows used in JustNN 
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Grid 

 
 

The Grid view shows all the Examples arranged in rows and all the Input/Outputs arranged in 

columns. The first column contains the Example types and names. The first row contains the 

Input/Output types and names. Everything on the Grid can be edited by moving to the cell 

containing the value and then pressing the enter key to start the Edit Grid dialog. The cell can be 

selected either using the arrow keys or the mouse. A single click will select the cell and a double 

click will start the Edit Grid dialog. A double click on the Example name cell will select the 

whole row and a double click on the Input/Output name cell will select the whole column. The 
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row or the column can be deselected by pressing the Esc key. 

 

Creating a New Grid. 

A new Grid is created by pressing the new toolbar button or using the File > New menu 

command. The new Grid will be empty except for a horizontal line, a vertical line and an 

underline marker that shows the current position in the Grid. New Grid rows and columns are 

created at the current position. 

 

Creating the first Example row and Input/Output column. 

Press return and a prompt will appear that says "Create new Example row?". Answer Yes. 

Another prompt will appear that says "Create new Input/Output column?". Answer Yes again. 

You will now see that the Grid has one cell containing "?", a row name containing "T:0" and a 

column name containing "I:0". The "?" indicates that the cell has no value, the "T:0" indicates 

that it is a Training Example in row 0 and the "I:0" indicates that is is an Input in column 0. Press 

return again and an Edit Grid dialog box will appear that allows you to enter the cell value. 

Using the same dialog you can change the Input/Output column name, mode and type. The 

dialog can also be used to change the Example row name and type.  

 

Creating more Input/Output columns. 

Move the marker one cell to the right by pressing the right arrow or tab key. Now press the 

return key and a prompt will appear that says "Create new Input/Output column?". Answer Yes. 

Press return again and the Edit Grid dialog box will appear. This time the Example row will 

already contain a name and type. You can set the cell value, the Input/Output name and the type 

can be set to "I:" for input, "O:" for output, "X:" for exclude or "S:" for serial. The mode can be 

set to "Real", "Integer", "Bool" or "Text". Any type of Input/Output column can be inserted into 

the Grid using the functions on the Insert menu. 

 

Creating more Example rows. 

Move the marker one cell down by pressing the down arrow key. Now press the return key and a 

prompt will appear that says "Create new Example row?". Answer Yes. Press return again and 

the Edit Grid dialog box will appear. This time the Input/Output column will already contain a 

name and type. You can set the cell value, Example name and the type can be set to T: for 

training, V: for validating, Q: for querying or X: for exclude. Any type of Example row be 

inserted into the Grid using the functions on the Insert menu. 

Copying Example rows and Input/Output columns. 

Double click on the name to select the whole row or column. Cut will remove the selected row or 

column and place it on the clipboard. Copy will place a copy of the selected row or column on 

the clipboard. Paste will insert a copy of the clipboard before the currently selected row or 

column. If the clipboard contains a row then Paste will insert the row into the Grid. If the 

clipboard contains a column then Paste will insert a column into the Grid. The invisible Grid 

data, limits and defaulted values, will be regenerated after a Paste column thus any neural 

network that has already been generated from the Grid will be invalidated. 

 

Column names 
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The columns can be named or numbered. 

 

Row names 

 
The rows can be named or numbered. 

 

Cell values 

 
The grid cell values can be integer, real, boolean or text. 



 9 

 

 

Network 

 
 

The Network view shows how the nodes in a JustNN neural network are interconnected.  
 
How to create a new neural network 
 
A new neural network can be created from the Grid by pressing the New Network toolbar button or 
selecting Action > New Network.  This will produce the New Network dialog.  This dialog allows the 
neural network configuration to be specified.  The dialog will already contain the necessary information to 
generate a neural network that will be capable of learning the information in the Grid.  However, the 
generated network may take a long time to learn and it may give poor results when tested.  A better 
neural network can be generated by checking Grow hidden layer 1 and allowing JustNN to determine the 
optimum number of nodes and connections.   
 
It is rarely necessary to have more than one layer of hidden nodes but JustNN will generate two or three 
hidden layers if Grow hidden layer 2 and Grow hidden layer 3 are checked.   
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The time that JustNN will spend looking for the optimum network can be controlled by setting the Growth 
rate variables.  Every time that the period expires JustNN will generate a new neural network slightly 
different from the previous one.  The best network is saved. 
 
 

Input node 

 
 

 

Hidden node 

 
Hidden nodes are fully connected to input nodes, output nodes or other layers of hidden 

nodes. 
 

Output node 

 
Output nodes are connected to the output columns in the grid. 

 

Connection weights 

 
The input layer is fully connected to the first hidden layer. Each connection has a weight 
that is updated while the network is learning. Hidden layers are fully connected the next 
hidden layer or the output layer. 
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Input Importance 

 
 

The Input Importance view shows the importance and the relative importance of each Input column.  
The Importance is the sum of the absolute weights of the connections from the input node to all the nodes 
in the first hidden layer.  The inputs are shown in the descending order of importance from the most 
important input.  
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Learning Progress 

 
 

The Learning Progress view shows how learning is progressing.  Up to 5000 graph points are recorded.  
This is sufficient for over 200,000,000 learning cycles.  The graph is produced by sampling these points.  
The horizontal axis is nonlinear to allow the whole learning progress to be displayed.  As more cycles are 
executed the graph is squashed to the left.  The scaled errors for all example rows are used.  The red line 
is the maximum example error, the blue line is the minimum example error and the green line is the 
average example error.  The orange line is the average validating error.  
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Toolbars 
 

Most functions in JustNN have toolbar icons 
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Main 

 
 

New 

 
Create a new document with a blank neural network grid 

 

Open 

 
Open an existing grid and neural network. 

 

Import 

 
Import a TXT, CSV, XLS, BMP or binary file into the neural network grid. 

 

Save 

 
Save the active neural network document. 

 

Information 

 
View the details of the currently open network file. 

 

Edit 
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Cut, copy and paste. The row or column is selected by double clicking the row or colunm 
name. 

 

Grid view 

 
View and edit the grid. 

 

Network view 

 
View the neural network. 

 

Importance view 

 
View the importance of the inputs. 

 

Learning progress 

 
View the learning progress graphs. 

 

New network 

 
Opens the New network dialog to create a neural network from the grid. 

 

Change controls 

 
Opens the controls dialog to set the learning, validating and other controls. 

 

Start learning 

 
Starts the learning process. 

 

Stop learning 

 
Stop the learning process. 
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Forget learning 

 
Forget learning.  The network weights are set to small random values.  The random number 
sequence is normally started at the same point when the network forgets but it can be restarted 
from a point based on the current time. 
 

 

Add query 

 
Adds a querying row to the grid. 

 

Change query value 

 
Increases, decreases, maximises or minimizes the query value. 

 

Zoom 

 
Zoom in or out. 

 

Support 

 
Email support. 
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Main Dialogs 
 

Most of the facilities in JustNN can be accessed or changed using dialogs. 
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Information 

 
 

Information.  Details of the neural network file are displayed when the file is loaded or when Information 
is selected on the menu. 
 

History 

 
Click to show the file loading and saving history. 
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Save 

 
Click to save all the information details to a text file. 

 

Refresh 

 
Click to refresh the information while the neural network is learning. 

 

Close 

 
Click to close the dialog. 
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Import TXT or CSV file 

 
 

Import.  Import a text or comma separated file. 
 
JustNN can import a txt or a csv file to create a new Grid or to add new example rows to an existing Grid. 
 
1.File > New to create a new Grid or File > Open to add rows to an existing Grid. 
 
2.File > Import... 
 
3.Open the file that is to be imported 
 
4.In the dialog check all the characters that are to be used for column delimiters.  Line ends are used for 
row delimiters. 
 
5.Any words before the first delimiter on each line can be used for row names.  If no row names are 
available then JustNN can generate numbers for row names. 
 
6.Press OK. 
 
 

Columns 
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Check the characters to use as Input/Output column delimiters. 

 

Row names 

 
Set how to produce Example row names. 

 

Row types 

 
Set the example row type for all imported rows or ask for row types while importing.   

 

OK 

 
Click to accept all settings and close the dialog. 

 

Cancel 

 
Click to reject all settings and close the dialog. 
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Import XLS file 

 
 

Import. Simple spreadsheet files produced by Excel in xls format can be imported directly into EasyNN-
plus but a much greater degree of import control is available if the files are first saved as comma 
separated csv types.  Files in xls format are limited to 256 columns and 65536 rows. 
 
If the xls file is to be imported directly to produce a new Grid proceed as follows. 
 
1.File > New to create a new Grid. 
 
2.File > Import... 
 
3.Open the xls file that is to be imported. 
 
4.Enter the name of the sheet that is to be imported if it is different to Sheet1. 
 
5.Answer the messages according to how you want to create the Grid Input/Output and Example names. 
 
6.Step through all the columns setting the type and mode. 
 

File name 

 
The file to be imported. 

 

Worksheet 

 
Enter the name of the worksheet to import. 
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OK button 

 
Click to accept settings and close the dialog. 

 

Cancel button 

 
Click to reject settings and close the dialog. 
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New Network 

 
 

Growth rate 

 
A network is produced when the cycles or seconds elapses until the optimum network is found. 

 

Input layer 

 
The number of nodes in the input layer is determined by the number of input columns in the grid. 

 

Hidden layers 
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The hidden layers are grown from the minimum to the maximum number of nodes. 

 

Output layer 

 
The number of nodes in the output layer is determined by the number of output columns in the 
grid. 

 

OK button 

 
Press to accept all the settings and close the dialog. 

 

Cancel button 

 
Press to reject all the settings and close the dialog. 
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Controls 

 
 

Learning 

 
 

 

Validating 
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Slow learning 

 
 

 

Target error stops 

 
 

 

Validating stops 

 
 

 

Fixed period stops 
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OK button 

 
Press to accept all the settings and close the dialog. 

 

Cancel button 

 
Press to reject all the settings and close the dialog. 
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Forget Learning 

 
 

ReSeed 

 
If checked, the random number generator is seeded starting at a value set by the current time. 

 

Weight range 

 
The range of values to set the weights and biases.  

 

OK 

 
Click to accept all settings and close the dialog. 

 

Cancel 

 
Click to  reject all settings and close the dialog. 
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Edit Grid 

 
 

Enter the grid cell value.  The value will be scaled to be from 0 to 1 using the column minimum and 
maximum. 
 

Value 

 
The value in the selected cell with column minimum, maximum and the scaled value. 

 

Example row 

 
Enter the example row name and set the type of row. 
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Input/Output column 

 
Enter the column name.  Set the column type and mode. 

 

OK 

 
Click to complete the edit and close the dialog. 
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AutoSave 

 
 

Backup 

 
Check to backup the file every ten minutes while the network is learning. 

 

Network details 

 
Check to save all details to the named text file on exit. 

 

Do not ask 

 
Check to stop this dialog being produced when learning is started. 

 

OK 

 
Press to accept all settings and close the dialog. 
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Cancel 

 
Press to reject all settings and close the dialog. 


